Blown, something?

Need to know how to setup your guitar? How do you lower your action? How do you get rid of the Milli Vanilli stickers? Look here first.
Post Reply
thomas_myers
newbie
Posts: 1
Joined: August 4th, 2018, 1:36 pm

Blown, something?

Post by thomas_myers » August 4th, 2018, 1:44 pm

So I'm in a bit of a pickle if you will as I seem to have royally f*cked something up. I was swapping my battery because the one that came with my guitar was getting old and the push-push boost on my MAJ100-ICR wasn't doing much. I somehow managed to accidentally put the battery in backwards and from what I hear that is pretty bad news. I don't want to bring it to a shop because the only one under 10 miles ripped me off the last time I went there and I don't feel like going back. (charged me $120 for a tube swap I didn't ask for instead of fixing the problem I had with my amp, which was a footswitch jack that doesn't work). I was wondering if anyone can help lead me in the right direction because I can't find much information on this issue online. When the battery is placed normally I get really shotty staticky output that is completely unplayable. When the battery is in backwards I get EXTREMELY low output and even with full gain and an overdrive pedal maxed out still sounds fairly clean. I'm assuming I blew some kind of transistor or preamp and I'm not sure where to go about fixing it.
UPDATE: I took a look under the hood and from what I see I blew what looks to be some kind of preamp that has to do with the push-push boost, I have no idea where to get replacement parts so if anybody could point me in the right directiont it would be greatly appreciated.
Image- https://www.ultimate-guitar.com/static/ ... 3%20PM.pdf

Post Reply