Active Epiphone, no sound

Need to know how to setup your guitar? How do you lower your action? How do you get rid of the Milli Vanilli stickers? Look here first.
Post Reply
zeroth
newbie
Posts: 1
Joined: February 8th, 2018, 6:53 am

Active Epiphone, no sound

Post by zeroth » February 8th, 2018, 7:03 am

I've got an Epiphone with two active pickups. I've had the thing for about 7 years. Some years it gets less attention. It might hang there on my wall for months at a time with a questionable battery inserted.

It's also worked fine, occasionally needing a battery replacement. But not I get no sound from it with a fresh battery, except a pop or click when turning the volume sometimes.

Here's the thing: if I put a dead battery in, I can get sound from it. The volume knob and toner switch don't change the volume or tone at all with the dead battery, but I can at least get some sound from it.

I popped the back panel of to examine the wires for anything that might've come loose but I don't see anything. I've got no experience repairing gutters (I'm a computer repair tech).

I'm considering taking the thing to Guitar Center but would rather learn something instead. I've reserved into it and can only conclude that there's a bad ground connection somewhere, and I might need to replace to clean up the potentiometer.

Any advice is welcome and appreciated!

nethanpaul
newbie
Posts: 14
Joined: August 22nd, 2018, 10:11 am

Re: Active Epiphone, no sound

Post by nethanpaul » August 28th, 2018, 9:30 am

That's so bad. If you want to have the genuine Epiphone parts then don't waste your time to go to the local shop for change. As there are better options avail at online just like FaberUSA, you may have the best guidance from them.

Post Reply